Opened 5 years ago

Last modified 5 years ago

#1149 new masalah

Gagal instal paket ia32-libs

Reported by: armansatari Owned by: dotovr
Priority: normal Milestone:
Component: PaketImpor Version: 8.0 (Rote)
Keywords: ia32libs Cc:

Description

Ketika ingin menginstal paket ia32-libs, ternyata dependensinya tdk terpenuhi.

Outputnya:

The following packages have unmet dependencies:

ia32-libs : Depends: ia32-libs-i386 but it is not installable

E: Unable to correct problems, you have held broken packages.

Mungkin bisa bantu pemecahannya. Terima kasih :)

Change History (3)

comment:1 Changed 5 years ago by dotovr

Paket ia32-libs telah mendukung multiarch, jadi dicoba saja dengan menambahkan arsitektur i386 :

sudo dpkg --add-architecture i386
sudo apt-get update

comment:2 Changed 5 years ago by armansatari

Saya sudah sempat mencoba cara tersebut. Tapi ternyata ada dependensi yang akan mengganti sebagian besar paket 64bit menjd paket 32bit.

Solusi yang sy lakukan adlh melihat isi dependensi ia32-libs dan instal semua.

sudo apt-get install libc6-i386 lib32asound2  lib32bz2-1.0 lib32gcc1 lib32ncurses5 lib32stdc++6 lib32v4l-0  lib32z1

catatan:

  • tidak perlu add list repo multiarch.

comment:3 Changed 5 years ago by princeofgiri

haris@rote:~$ sudo aptitude install ia32-libs
The following NEW packages will be installed:

ia32-libs{b}

0 packages upgraded, 1 newly installed, 0 to remove and 3 not upgraded.
Need to get 113 kB of archives. After unpacking 137 kB will be used.
The following packages have unmet dependencies:

ia32-libs : Depends: ia32-libs-i386 which is a virtual package.

The following actions will resolve these dependencies:

Keep the following packages at their current version:

1) ia32-libs [Not Installed]

Accept this solution? [Y/n/q/?]

Masih puyenk

Note: See TracTickets for help on using tickets.